poj 3259 Wormholes (最短路 Bellma_ford)

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

#include <iostream>
#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
#define MAX 6000

using namespace std;

struct node
{
    int x,y,w;
} E[MAX];

int dis[MAX];
int N,M,W;
int top;

bool Bellman_ford()
{
    memset(dis,INF,sizeof(dis));
    dis[1] = 0;
    bool flag;
    for(int i=1; i<N; i++)
    {
        flag = false;
        for(int j=0; j<top; j++)
        {
            if(dis[E[j].x] < INF && dis[E[j].y] > dis[E[j].x] + E[j].w)
            {
                flag = true;
                dis[E[j].y] = dis[E[j].x] + E[j].w;
            }
        }
        if(!flag)
            break;
    }
    for(int j=0; j<top; j++)
    {
        if(dis[E[j].x] < INF && dis[E[j].y] > dis[E[j].x] + E[j].w)
        {
            return true;
        }
    }
    return false;
}
int main()
{
   // freopen("in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        top = 0;
        scanf("%d%d%d",&N,&M,&W);
        int a,b,c;
        for(int i=0; i<M; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            E[top].x = a;
            E[top].y = b;
            E[top++].w = c;
            E[top].x = b;
            E[top].y = a;
            E[top++].w = c;
        }
        for(int i=0; i<W; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            E[top].x = a;
            E[top].y = b;
            E[top++].w = -c;
        }
        if(Bellman_ford())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}



你可能感兴趣的:(poj 3259 Wormholes (最短路 Bellma_ford))