Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A
i,j = 1 means i-th people loves j-th people, otherwise A
i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A
i,i= 0, A
i,j ≠ A
j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
Author
BJTU
Source
2012 Multi-University Training Contest 3
Recommend
简单题,判断是否有环,拓扑排序搞定
#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=2005;
struct node
{
int next;
int to;
}edge[N*N];
int head[N];
int tot,n;
char str[N];
int in_degree[N];
void addedge(int from,int to)
{
edge[tot].to=to;
edge[tot].next=head[from];
head[from]=tot++;
}
void init()
{
memset(head,-1,sizeof(head));
memset(in_degree,0,sizeof(head));
tot=0;
}
void topo_sort()
{
int cnt=0;
queue<int>qu;
while (!qu.empty())
qu.pop();
for (int i=1;i<=n;i++)
if (!in_degree[i])
qu.push(i);
while (!qu.empty())
{
int u=qu.front();
qu.pop();
cnt++;
for (int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
in_degree[v]--;
if(!in_degree[v])
qu.push(v);
}
}
if(cnt==n)
printf("No\n");
else
printf("Yes\n");
}
int main()
{
int t;
int icase=1;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
init();
for(int i=1;i<=n;i++)
{
scanf("%s",str);
for(int j=0;j<n;j++)
if(str[j]=='1')
{
addedge(i,j+1);
in_degree[j+1]++;
}
}
printf("Case #%d: ",icase++);
topo_sort();
}
return 0;
}