http://acm.hdu.edu.cn/showproblem.php?pid=2845&&最大不连续数和

Beans

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1176 Accepted Submission(s): 615


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
http://acm.hdu.edu.cn/showproblem.php?pid=2845&&最大不连续数和_第1张图片

Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
   
   
   
   
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output
   
   
   
   
242
题意:最大不连续和问题,如果选中(x,y),那么x-1和x+1行不能选,(x,y-1)和(x,y+1)也不能选,,,状态转移方程
b[i]=max(b[i-2]+b[i],b[i-1])
AC代码:
#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
#define N 200005
using namespace std;
int a[N],b[N];
int main()
{
  int n,m;
  while(cin>>n>>m)
  {  memset(b,0,sizeof(b));
      for(int i=1;i<=n;++i)
         {
             for(int j=1;j<=m;++j)
               cin>>b[j];
              for(int j=2;j<=m;++j)
              b[j]=max(b[j-2]+b[j],b[j-1]);
              a[i]=b[m];
          }
      for(int i=2;i<=n;++i)
          a[i]=max(a[i-2]+a[i],a[i-1]);
      cout<<a[n]<<endl;
  }return 0;
}



你可能感兴趣的:(http://acm.hdu.edu.cn/showproblem.php?pid=2845&&最大不连续数和)