ACM--抛物线和直线围成的面积–-HDOJ 1071--The area--水

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9539    Accepted Submission(s): 6724


Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

ACM--抛物线和直线围成的面积–-HDOJ 1071--The area--水_第1张图片
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
   
   
   
   
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
   
   
   
   
33.33 40.69

题意:要我们求抛物线和直线围成的面积,抛物线方程是y=a*x^2+b*x+c,直线的方程是y=k*x+h,

已知抛物线与直线相交两点和抛物线顶点,顶点P1(-b/(2a), (4ac-b^2)/4a)。
我们已知p1,p2,p3,然后求出 a,b,c,k,h
y1=ax1^2+bx1+c
y2=ax2^2+bx2+c
y1-y2=(x1-x2)(a(x1+x2)+b)


又x1=-b/2a,
所以a=(y2-y1)/(x2-x1)^2
 
面积用积分公式化简为:
 S=a/3*(x3^3–x2^3)+(b-k)/2*(x3^2–x2^2)+(c-h)*(x3-x2);


#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
int main(){
    int n;
    double x1,y1,x2,y2,x3,y3,a,b,c,k,h,s;
    cin>>n;
    while(n--){
        cin>>x1>>y1>>x2>>y2>>x3>>y3;
        a=(y2-y1)/((x2-x1)*(x2-x1));
        b=-2*a*x1;
        c=y1-a*x1*x1-b*x1;
        k=(y3-y2)/(x3-x2);
        h=y2-k*x2;
        s=a/3*(x3*x3*x3-x2*x2*x2)+(b-k)/2*(x3*x3-x2*x2)+(c-h)*(x3-x2);
        printf("%.2f\n",s);
    }
}


你可能感兴趣的:(数学,ACM,area,hdoj,1071,the)