背包问题(天平)——POJ 1837

对应POJ题目:点击打开链接

Balance
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 1837

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2


题意:一个天平有n个挂钩,第i个挂钩到中心的距离为C[i],负数表示在左边,正数表示在右边;然后有m个砝码,问把所有砝码放在挂钩上使天平平衡的方法有多少种。


思路:dp[i][j]表示放前i个砝码时,形成j力矩的最多方法数,j的最小值为-20*25*15 = -7500,故应使j右移7500。则状态转移方程为:dp[i][j] += dp[i-1][j - C[k]*G[i]];


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 25
#define M 15010
int dp[N][M];
int C[N];
int G[N];

int main()
{
	//freopen("in.txt", "r", stdin);
	int nc, ng;
	int i, j, k;
	while(~scanf("%d%d", &nc, &ng))
	{
		for(i = 0; i < nc; i++)
			scanf("%d", C + i);
		for(i = 1; i <= ng; i++)
			scanf("%d", G + i);
		memset(dp, 0, sizeof(dp));
		dp[0][7500] = 1;
		for(i = 1; i <= ng; i++)
			for(j = 0; j < M; j++)
				for(k = 0; k < nc; k++)
					dp[i][j] += dp[i-1][j-C[k]*G[i]];
		printf("%d\n", dp[ng][7500]);
	}
	return 0;
}





你可能感兴趣的:(背包问题(天平)——POJ 1837)