NYOJ-17-单调递增最长子序列

描述
求一个字符串的最长递增子序列的长度
如:dabdbf最长递增子序列就是abdf,长度为4
输入
第一行一个整数0 < n < 20,表示有n个字符串要处理
随后的n行,每行有一个字符串,该字符串的长度不会超过10000
输出
输出字符串的最长递增子序列的长度
样例输入
3
aaa
ababc
abklmncdefg
样例输出
1
3
7

水题喽……

#include <stdio.h>
#include <string.h>
char strA[10001], strB[50];

int upper_bound(int A, int key)
{
    for (int i = 0; i < key; i++)
    {
        if (strB[i] >= A)
        {
            return i;
        }
    }
    return key;
}

int main(int argc, const char * argv[])
{
    int n;
    scanf("%d", &n);

    while (n--)
    {
        scanf("%s", strA);

        int len = (int)strlen(strA);
        int key = 0;
        strB[key] = strA[key];

        for (int i = 1; i < len; i++)
        {
            if (strA[i] > strB[key])
            {
                strB[++key] = strA[i];
            }
            else
            {
                strB[upper_bound(strA[i], key)] = strA[i];
            }
        }

        printf("%d\n", key + 1);
    }

    return 0;
}

你可能感兴趣的:(LIS,动归)