hdu1698--Just a Hook(线段树修改区间值,求区间和)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16817 Accepted Submission(s): 8360


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

hdu1698--Just a Hook(线段树修改区间值,求区间和)_第1张图片

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
   
   
   
   
1 10 2 1 5 2 5 9 3

Sample Output
   
   
   
   
Case 1: The total value of the hook is 24.
题意:修改x到y的值为k,最后统计总和;
用线段树来做,数组v[i]表示节点i所控制的所有值都为v[i],如果要更新出新的值,将原来的v[i]向下推,同事更新数组。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int tree[2000000] , v[2000000] ;
void init(int o,int x,int y)
{
    if(x == y)
        tree[o] = 1 ;
    else
    {
        int mid  = (x + y)/ 2 ;
        init(o*2,x,mid);
        init(o*2+1,mid+1,y);
        tree[o] = tree[o*2] + tree[o*2+1] ;
    }
}
void f(int o)
{
    if( v[o] )
    {
        v[o*2] = v[o*2+1] = v[o] ;
        v[o] = 0 ;
    }
}
void maintain(int o,int x,int y)
{
    if( v[o] )
    {
        tree[o] = v[o] * (y-x+1) ;
    }
    else if(x != y)
        tree[o] = tree[o*2] + tree[o*2+1] ;
}
void update(int o,int x,int y,int i,int j,int k)
{
    if( i <= x && y <= j )
        v[o] = k ;
    else
    {
        f(o) ;
        int mid = (x + y)/2 ;
        if( i <= mid )
            update(o*2,x,mid,i,j,k);
        else
            maintain(o*2,x,mid);
        if( mid+1 <= j )
            update(o*2+1,mid+1,y,i,j,k);
        else
            maintain(o*2+1,mid+1,y);
    }
    maintain(o,x,y);
}
int sum(int o,int x,int y,int i,int j)
{
    int ans = 0 ;
    if( v[o] )
    {
        ans = v[o] * ( min(y,j) - max(x,i) + 1 );
    }
    else if( i <= x && y <= j )
    {
        ans += tree[o] ;
    }
    else
    {
        int mid = (x + y) /2 ;
        if( i <= mid )
            ans += sum(o*2,x,mid,i,j);
        if( mid+1 <= j )
            ans += sum(o*2+1,mid+1,y,i,j);
    }
    return ans ;
}
int main()
{
    int tt , t , i , n , m , x , y , k ;
    scanf("%d", &t);
    for(tt = 1 ; tt<= t ; tt++)
    {
        memset(tree,0,sizeof(tree));
        memset(v,0,sizeof(v));
        scanf("%d", &n);
        init(1,1,n);
        scanf("%d", &m);
        while(m--)
        {
            scanf("%d %d %d", &x, &y, &k);
            update(1,1,n,x,y,k) ;
        }
        printf("Case %d: The total value of the hook is %d.\n", tt , sum(1,1,n,1,n));
    }
    return 0;
}


你可能感兴趣的:(hdu1698--Just a Hook(线段树修改区间值,求区间和))