hdu 1506 Largest Rectangle in a Histogram 单调队列

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12554    Accepted Submission(s): 3509


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
hdu 1506 Largest Rectangle in a Histogram 单调队列_第1张图片
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
   
   
   
   
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
   
   
   
   
8 4000
 



题意:
输入n个柱子,并排放。问最大的矩形面积。

要维护两个单调队列,lft和rit。lft [i]表示i点,左边连续有比i点高的柱子的话,把最左边的柱子编号记录在lft [i]。 rit 同理,记录i的最右边连续比i高的柱子的编号。

第一个案例:
id 1 2 3 4 5 6 7
h  2 1 4 5 1 3 3
lft 1 1 3 4 1 6 6
rit 1 7 4 4 7 7 7

有了lft 和rit 就可枚举每一列计算那一列向两遍扩展的最大的宽了。再乘上该列的高,就是包含该列的最大的面积了。
 




#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>  


long long h[100010],lft[100010],rit[100010];

int main()
{ 
	long long n,m,t;

	while(cin>>n,n)
	{
		for(long long i=1;i<=n;i++) 
		{
			cin>>h[i]; 
			lft[i]=rit[i]=i;
		}

		h[0]=h[n+1]=-1;
		for(long long i=1;i<=n;i++)
		{ 
			while(h[i]<=h[lft[i]-1])
				lft[i]=lft[lft[i]-1];
		}

		for(long long i=n;i>=1;i--)
		{
			while(h[i]<=h[rit[i]+1])
				rit[i]=rit[rit[i]+1];
		}

		long long maxx=0;
		for(long long i=1;i<=n;i++)
			maxx=max(maxx,h[i]*(rit[i]-lft[i]+1));
		printf("%I64d\n",maxx);

		for(int i=1;i<=n;i++)
		{
			printf("%d ",lft[i]);
		}
		puts("");
		for(int i=1;i<=n;i++)
		{
			printf("%d ",rit[i]);
		}
		puts("");
	} 
	
	return 0;
} 
/*
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
*/




你可能感兴趣的:(单调队列)