120 - Stacks of Flapjacks

Stacks of Flapjacks

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake’s diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake “flips”. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

     8           7           2
     4           6           5
     6           4           8
     7           8           4
     5           5           6
     2           2           7

The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

有一叠煎饼正在锅里。煎饼共有n(n≤30)张,每张都有一个数字,代表它的大小,如图所示。厨师每次可以选择一个数k,把从锅底开始数第k张上面的煎饼全部翻过来,即原来在上面的煎饼现在到了下面。例如(a),依次执行操作f(3),f(1)后得到图(c)的情况。

     8           7           2
     4           6           5
     6    ->     4    ->     8
     7           8           4
     5           5           6
     2           2           7
    (a)         (b)         (c)

设计一种方法使得所有煎饼按照从小到大排序(最上面的煎饼最小)。输入时,各个煎饼按照从上到下的顺序给出。例如,上面的例子输入为8, 4, 6, 7, 5, 2。

//#define LOCAL
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>

using namespace std;

const int maxNum = 30 + 5;
const int INF = 100000000;

void solve(int *cake, int n) {
    vector<int> ans;
    // 复制一份序列
    int tmp[n];
    for(int i = 0; i < n; i++) {
        tmp[i] = cake[i];
    }
    // 利用选择排序的思想
    for(int i = n - 1; i >= 0; i--) {
        int max = -INF;
        // 下标
        int x = i;
        // 寻找 0 - i 之间的最大值
        for(int j = i; j >= 0; j--) {
            if(max < tmp[j]) {
                max = tmp[j];
                x = j;
            }
        }
        // 如果第i大数的已经排好序,则无需操作
        if(x == i) {
            continue;
        } else if(x == 0) {
            // 如果第i大的在第一个,则只需将0 - i之间的数翻转一次
            reverse(tmp, tmp + i + 1);
            ans.push_back(n - i);
        } else {
            // 否则,需要先将从 0 - x 之间的翻转一次,再将0 - i之间的数翻转一次
            reverse(tmp, tmp + x + 1);
            ans.push_back(n - x);
            reverse(tmp, tmp + i + 1);
            ans.push_back(n - i);
        }
    }
    // 结尾加0
    ans.push_back(0);
    // 输出
    cout << cake[0];
    for(int i = 1; i < n; i++) {
        cout << " " << cake[i];
    }
    cout << endl;
    cout << ans[0];
    for(int i = 1; i < ans.size(); i++) {
        cout << " " << ans[i];
    }
    cout << endl;
}

int main() {
    #ifdef LOCAL
        freopen("data.120.in", "r", stdin);
        freopen("data.120.out", "w", stdout);
    #endif // LOCAL
    string s;
    while(getline(cin, s)) {
        // pancake的数量
        int num = 0;
        int cake[maxNum];
        int sum = 0;
        // 转换为整数数组
        for(int i = 0; i < s.length(); i++) {
            if(s[i] == ' ') {
                cake[num++] = sum;
                sum = 0;
            } else {
                sum = (sum * 10) + (s[i] - '0');
            }
        }
        // 处理最后一个数字
        cake[num++] = sum;

        solve(cake, num);
    }
}

你可能感兴趣的:(ACM,uva,uva120)