POJ 2407-Relatives-欧拉函数

Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12903   Accepted: 6379

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source

Waterloo local 2002.07.01

题意:
给定一个数n,求所有小于等于n的正整数中,有多少个是与n互质的。

知识点:
欧拉函数,直接套模板。

#include<iostream>
using namespace std;

int oula(int n)//欧拉函数的函数模板
{
    int i,ans=n;
    for(i=2;i*i<=n;++i)
        if(n%i==0)
    {
        ans-=ans/i;
        while(n%i==0)
            n/=i;
    }
    if(n>1)
        ans-=ans/n;
    return ans;
}

int main()
{
	int n;
	while(cin>>n&&n)
        cout<<oula(n)<<endl;
	return 0;
}


你可能感兴趣的:(poj,欧拉函数,Relatives)