HDU 2602 Bone Collector (0-1背包问题)

题目:

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2  31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

这个题目只是最简单的0-1背包问题,不说话了,直接上代码

代码:

#include<iostream>
#include<string.h>
using namespace std;

int value[1001];
int volume[1001];
int list[1001];

int main()
{
	int cas;
	cin >> cas;
	int N, V;
	while (cas--)
	{
		cin >> N >> V;
		memset(value, 0, sizeof(value));
		memset(volume, 0, sizeof(volume));
		memset(list, 0, sizeof(list));
		for (int i = 1; i <= N; i++)cin >> value[i];
		for (int i = 1; i <= N; i++)cin >> volume[i];
		for (int i = 1; i <= N; i++)
		for (int j = V; j >= volume[i]; j--)
		if (list[j] < list[j - volume[i]] + value[i])
                    list[j] = list[j - volume[i]] + value[i];
		cout << list[V] << endl;
	}
	return 0;
}

你可能感兴趣的:(HDU 2602 Bone Collector (0-1背包问题))