二分查找(HDU 2141 )

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 27535    Accepted Submission(s): 6920


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
 
   
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
 
   
Case 1: NO YES NO
 

Author
wangye
 

Source
HDU 2007-11 Programming Contest
 

Recommend
威士忌


思路:只是一道典型的二分查找题目;

二分。
    输入有三个集合,要先合并两个为一,然后再对这个
合并出来的集合进行二分;否则不合并的话,直接用双层
for嵌套一个二分,会TLE的。
    前者最坏情况:T*(25W+500*18*1000);
    后者最坏情况:T*(1250W*10*1000),显然TLE。


#include"stdio.h"
#include"string.h"
#include"stdlib.h"

int tot[3];
int x[511];
int y[511];
int z[511];
int d[251111],k;

int cmp(const void *a,const void *b)
{
    return *(int *)a-*(int *)b;
}
int main()
{

    int Case=1,n;
    int i,l;
    int aim,tmp,flag;
    int low,up,mid;

    while(scanf("%d%d%d",&tot[0],&tot[1],&tot[2])!=-1)
    {
        qsort(tot,3,sizeof(tot[0]),cmp);
        for(i=0;i>1;
                while(up-low>1)
                {
                    if(d[mid]>tmp) up=mid;
                    else if(d[mid]>1;
                }
                if(d[low]==tmp||d[up]==tmp) flag=1;
                if(flag) break;
            }
            if(flag) printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}




你可能感兴趣的:(二分搜索)