POJ-2488 A Knight's Journey

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

POJ-2488 A Knight's Journey_第1张图片
题解:DFS 这道题相当于马走日(上图)然后要把每个点都走一遍然后输出来,横ABCD…,竖12345…
我们要用一个path数组存储一下每次走的是哪个点。方便输出。

#include<iostream>
#include<cstring>
using namespace std;
const int N=100;
int g[N][N];
int vis[N][N]; //判断当前点有没有走过
int path[N][N]; //存储每次走的是哪个点
int p,q;
int flag; //标记一下有没有全部走完
int dx[8]={-1, 1, -2, 2, -2, 2, -1, 1};  // 马走日的八种情况,大家可以根据上面的图,来判断
int dy[8]={-2, -2, -1, -1, 1, 1, 2, 2};
void dfs(int l,int r,int u)
{
	path[u][0]=l; //把当前走的点,x,y小标存储起来
	path[u][1]=r;
	if(u==p*q)  //如果每个点都走过了,意思全部走完了p*q;
	{
		flag=1;
		return ;
	}
	for(int i=0;i<8;i++) //枚举八个点,马走日的情况
	{
		int x=l+dx[i],y=r+dy[i];  
		if(x>=1&&x<=p&&y>=1&&y<=q&&!flag&&!vis[x][y]) //判断边界符不符合条件且未标记过
		{
			vis[x][y]=1; //先标记
			dfs(x,y,u+1); //然后到下一个点
			vis[x][y]=0; //恢复现场
		}
	}
}
int main()
{
	int n;
	cin>>n;
	int k=n;
	while(n--)
	{
		flag=0;
		memset(vis,0,sizeof(vis)); //初始化
		vis[1][1]=1; //起始点标记一下,已经走过了
		scanf("%d %d",&p,&q);
		dfs(1,1,1); 
		printf("Scenario #%d:\n",k-n);
		if(flag) 
		{
			for(int i=1;i<=p*q;i++)
				printf("%c%d",path[i][1]-1+'A',path[i][0]);
			printf("\n");
		}
		else
		{
			printf("impossible\n");
		}
		printf("\n");
	}
	return 0;
 } 

你可能感兴趣的:(BFS)