Bi-shoe and Phi-shoe

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1

Sample Output

Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

题意:给你几个数,你需要求出这些数的对应值的和,每个数的对应值是其欧拉函数大于或等于这个数的素数;而素数p的欧拉函数值为p-1;

思路:素数打表;

代码:

#include"stdio.h"
#include"string.h"
int prime[2000010];
int main()
{
	int i,j;
	for(i=2;i*i<2000000;i++)
	{
		if(!prime[i])
		{
			for(j=i*i;j<=2000000;j+=i)
			prime[j]=1;
		}
	}
	int t,k=1;
	scanf("%d",&t);
	while(t--)
	{
		int m,n;
		long long s=0;
		scanf("%d",&m);
		for(i=0;i<m;i++)
		{
			scanf("%d",&n);
			for(j=n+1;;j++)
			{
				if(!prime[j])
				{
					s+=j;
					break;
				}
			}
		}
		printf("Case %d: %lld Xukha\n",k++,s);
	}
	return 0;
}

你可能感兴趣的:(Bi-shoe and Phi-shoe)