Oil Deposits (八个方向搜索)

题目描述:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2

代码:

import java.util.Scanner;
public class oildeposits {
    static int m,n,ans;
    static int map[][]=new int[150][150];
    //static int book[][]=new int[150][150];不需要book数组
    static int b[][]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};//八个方向(左上,上,右上,左,右,左下,下,右下)
    static void dfs(int x,int y){
        map[x][y]=0;//将当前位置替换
    	for(int i=0;i<8;i++){
    		int xx=x+b[i][0];
    		int yy=y+b[i][1];
    		if(xx<0 ||yy<0 ||xx>=m||yy>=n)continue;
    		if(map[xx][yy]==0)continue;
    		//book[xx][yy]=1;
    		dfs(xx,yy);
    		//book[xx][yy]=0;
    	}
    }
	public static void main(String[] args) {
		// TODO Auto-generated method stub
       Scanner scan=new Scanner(System.in);
       while(scan.hasNext()){
    	   m=scan.nextInt();
    	   n=scan.nextInt();
    	   if(m==0)break;
    	   for(int i=0;i


你可能感兴趣的:(深搜)