HDU——1598 find the most comfortable road (枚举+并查集)

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1598

HDU——1598 find the most comfortable road (枚举+并查集)_第1张图片
样例:

Sample Input
4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2
 

Sample Output
1
0

题意: 给定n座城市和m条城市之间的道路信息。接下来有q条询问,给出起点城市编号和终点城市编号,问能否到达,若能,求出最小的最小限速的最大限速的差值。

解题思路: 这道题首先要求的就是给定的城市是否连通,然后还要求得差值最小。对于判断是否连通我们可以利用并查集来处理,对于差值最小我们则可以使用枚举方法先对道路信息按限速进行排序,然后枚举所有可能的情况再取最小值。具体看代码。

AC代码:

/*
*邮箱:[email protected]
*blog:https://me.csdn.net/hzf0701
*注:文章若有任何问题请私信我或评论区留言,谢谢支持。
*
*/
#include	//POJ不支持

#define rep(i,a,n) for (int i=a;i<=n;i++)//i为循环变量,a为初始值,n为界限值,递增
#define per(i,a,n) for (int i=a;i>=n;i--)//i为循环变量, a为初始值,n为界限值,递减。
#define pb push_back
#define IOS ios::sync_with_stdio(false);cin.tie(0); cout.tie(0)
#define fi first
#define se second
#define mp make_pair

using namespace std;

const int inf = 0x3f3f3f3f;//无穷大
const int maxn = 1e3+2;//最大值。
typedef long long ll;
typedef long double ld;
typedef pair<ll, ll>  pll;
typedef pair<int, int> pii;
//*******************************分割线,以上为自定义代码模板***************************************//

struct Edge{
	int u,v;//道路的两个顶点。
	int w;//道路速度。
	bool operator< (const Edge &a){
		//运算符重载。
		return w<a.w;
	}
};
Edge edges[maxn];//边集合。
int n,m,q;//n个城市。m条道路。
int father[maxn];
int Find(int x){
	int r=x;
	while(r!=father[r])
		r=father[r];
	int i=x,j;
	//压缩路径
	while(father[i]!=r){
		j=father[i];
		father[i]=r;
		i=j;
	}
	return r;
}
void Merge(int x,int y){
	int fx=Find(x),fy=Find(y);
	if(fx!=fy)
		father[fx]=fy;
}
void solve(int u,int v){
	int flag,minn=inf;
	rep(i,0,m-1){
		flag=false;
		rep(k,1,n)father[k]=k;
		rep(j,i,m-1){
			Merge(edges[j].u,edges[j].v);
			if(Find(u)==Find(v)){
				flag=true;
				minn=min(minn,edges[j].w-edges[i].w);
				break;
			}
		}
		if(!flag)break;
	}
	if(minn==inf)cout<<-1<<endl;
	else cout<<minn<<endl;
}
int main(){
	//freopen("in.txt", "r", stdin);//提交的时候要注释掉
	IOS;
	while(cin>>n>>m){
		int u,v,w;
		rep(i,0,m-1){
			cin>>u>>v>>w;
			edges[i].u=u;
			edges[i].v=v;
			edges[i].w=w;
		}
		cin>>q;
		sort(edges,edges+m);
		while(q--){
			cin>>u>>v;
			solve(u,v);
		}
	}
	return 0;
}

你可能感兴趣的:(#,并查集,#,HDU)