hdu 1711 Number Sequence KMP

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1711

分析:求最小偏移位置使得两字符串匹配,KMP应用。

/*Number Sequence



Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12466    Accepted Submission(s): 5687





Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 



Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 



Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 



Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

 



Sample Output

6

-1

 



Source

HDU 2007-Spring Programming Contest

*/

#include <cstdio>

const int maxn = 10000 + 10, maxm = 1000000 + 10;

int n, m;

int p[maxn], t[maxm], next[maxn]; //定义模式串,文本串,next数组 

void getNext() //O(m)复杂度求Next数组 

{

    int i = 0, j = 0, k = -1;

    next[0] = -1;

    while(j < m){

        if(k == -1 || p[k] == p[j]) next[++j] = ++k;

        else k = next[k];

    }

}

int kmp()

{

    int j = 0; //初始化模式串的前一个位置 

    getNext(); //生成next数组 

    for(int i = 0; i < n; i++){//遍历文本串 

        while(j && p[j] != t[i]) j = next[j];//持续走直到可以匹配 

        if(p[j] == t[i]) j++; //匹配成功继续下一个位置 

        if(j == m) return i-m+2; //找到后返回第一个匹配的位置 

    }

    return -1; //找不到返回-1 

}



int main()

{

    int T;

    scanf("%d", &T);

    while(T--){

        scanf("%d%d", &n, &m);

        for(int i = 0; i < n; i++) scanf("%d", t+i);

        for(int i = 0; i < m; i++) scanf("%d", p+i);

        printf("%d\n", kmp());

    }

    return 0;

}

 

你可能感兴趣的:(sequence)