HDU1393:Weird Clock

Problem Description
A weird clock marked from 0 to 59 has only a minute hand. It won't move until a special coin is thrown into its box. There are different kinds of coins as your options. However once you make your choice, you cannot use any other kind. There are infinite number of coins of each kind, each marked with a number d ( 1 <= d <= 1000 ), meaning that this coin will make the minute hand move d times clockwise the current time. For example, if the current time is 45, and d = 2. Then the minute hand will move clockwise 90 minutes and will be pointing to 15.

Now you are given the initial time s ( 1 <= s <= 59 ) and the coin's type d. Write a program to find the minimum number of d-coins needed to turn the minute hand back to 0.
 

 

Input
There are several tests. Each test occupies a line containing two positive integers s and d.

The input is finished by a line containing 0 0.
 

 

Output
For each test print in a single line the minimum number of coins needed. If it is impossible to turn the hand back to 0, output "Impossible".
 

 

Sample Input
30 1 0 0
 

 

Sample Output
1
 


 

//这题真的很恶心,首先英文我救不说了,而且还表达不清

 

#include <stdio.h>



int main()

{

    int s,d;

    while(~scanf("%d%d",&s,&d) && (s||d))

    {

        if(!s)

        {

            printf("1\n");

            continue;

        }

        int k = 0,cnt = 0;

        while(s%60)

        {

            if(cnt > 1000)

            {

                k = 1;

                break;

            }

            s = s+s*d;

            s%=60;

            cnt++;

        }

        if(k)

            printf("Impossible\n");

        else

            printf("%d\n",cnt);

    }



    return 0;

}


 

 

你可能感兴趣的:(Lock)