HDOJ 1719 Friend(数学归纳)

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2232    Accepted Submission(s): 1120


Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
   
   
   
   
3 13121 12131
 

Sample Output
   
   
   
   
YES! YES! NO!
 
 
规律题越来越差。
 

题意:

(1.)   1,2都是friend数

(2.)   如果a,b都是friend数,那么ab+a+b也是friend数

(3.)   满足一二两条才是friend数。

 

给出n,判断n是否是friend数。

 

题解:判断是否是friend数就是判断是否是1,2或者是a*b+a+b的形式。  设n是friend数,且是由a*b+a+b组成的。

 

                那么得n=a*b+a+b,  得n+1=(a+1)*(b+1)。   因为对于a,b的取值最原始的数1,2。  所以由归纳法可知

 

                 n为friend数的通项式为,n=(1+1)^x * (2+1)^y=2^x * 3^y。

 

具体代码如下:

 

<span style="font-size:12px;">#include<cstdio>
int main()
{
	int n,x,y;
	while(scanf("%d",&n)!=EOF)
	{
		n+=1;
		x=y=0;
        while(n%2==0)
        {
        	n/=2;
        	x++;
        }
        while(n%3==0)
        {
        	n/=3;
        	y++;
        }
        if(n==1&&(x>0||y>0))//判断n是否是只由2或者3为因子组成的。(1不计入) 
           printf("YES!\n");
        else 
           printf("NO!\n");
	}
	return 0;
}</span>


 

你可能感兴趣的:(HDOJ 1719 Friend(数学归纳))