ZOJ 3203 Light Bulb






Light Bulb Time Limit: 1 Second       Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

ZOJ 3203 Light Bulb_第1张图片

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
 题目大意:

如图,人左右走动,求影子L的最长长度。根据图,很容易发现当灯,人的头部和墙角成一条直线时(假设此时人站在A点),此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人从A点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用  三分法 来求解。

(小数据量,暴力也能解出来,约300ms,用三分的话0ms)

代码如下:

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

double H, h, d, sum;
double calc(double l)
{
    return l + d * (h - l) / (H - l);
}
int main()
{
#ifdef test
    freopen("in.txt", "r", stdin);
#endif
    int num;
    scanf("%d",&num);
    while(num--)
    {
        scanf("%lf%lf%lf",&H,&h,&d);
        double left = 0, right = h;
        while(left + 0.00001 < right)
        {
            double mid = (left + right) / 2;
            double mimid = (mid + right) / 2;
            if(calc(mid) > calc(mimid))
                right = mimid;
            else
                left =mid;
        }
        printf("%.3lf\n",calc(left));
    }
    return 0;
}


你可能感兴趣的:(input,UP,each,output,distance,Numbers)