hdu1087

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
   
   
   
   
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
   
   
   
   
4 10 3
 

如果j>i且是s[j] >s[i],则在第i个位置可以跳到第j个位置,是s[i],s[j]代表该位置的分数,求最总能够获得的最大分数.



#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=1001;
int dp[MAX],s[MAX];//dp为能够到达当前这个位置时可得的最大值. 

int main(){
	int n;
	while(cin>>n,n){
		for(int i=0;i<n;++i){
			cin>>s[i];
		}
		dp[0]=s[0];
		int Max=dp[0];
		for(int i=1;i<n;++i){
			int sum=s[i];
			for(int j=0;j<i;++j){//求dp[i]的最大值就是求在i以前的比s[i]小的最大的dp[j]+s[i]; 
				if(s[i]>s[j])sum=max(sum,dp[j]+s[i]);
			}
			dp[i]=sum;
			Max=max(Max,dp[i]); 
		}
		cout<<Max<<endl;
	}
	return 0;
}


你可能感兴趣的:(hdu1087)