题目链接:
Matrix
Time Limit: 3000MS |
|
Memory Limit: 65536K |
Total Submissions: 23170 |
|
Accepted: 8613 |
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e3+4;
int sum[N][N],n,l,r,xl,xr,yl,yr,m;
char c;
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int y,int num)
{
while(y<=n)
{
int fx=x;
while(fx<=n)
{
sum[fx][y]+=num;
fx+=lowbit(fx);
}
y+=lowbit(y);
}
}
int query(int x,int y)
{
int s=0;
while(y>0){
int fx=x;
while(fx>0)
{
s+=sum[fx][y];
fx-=lowbit(fx);
}
y-=lowbit(y);
}
return s;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(sum,0,sizeof(sum));
scanf("%d%d",&n,&m);
for(int i=0;i<m;i++)
{
cin>>c;
if(c=='C')
{
scanf("%d%d%d%d",&xl,&yl,&xr,&yr);
update(xl,yl,1);
update(xl,yr+1,1);
update(xr+1,yl,1);
update(xr+1,yr+1,1);
}
else
{
scanf("%d%d",&l,&r);
printf("%d\n",query(l,r)%2);
}
}
printf("\n");
}
return 0;
}