杭电1195 open the lock (搜索题)BFS

Open the Lock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5504    Accepted Submission(s): 2456


Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9. 
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases. 

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
   
   
   
   
2 1234 2144 1111 9999
 

Sample Output
   
   
   
   
2 4

题目大意:

把上边的串用最少的操作变成下边的串.

操作一共分三类,11种操作:

 zifuchuan  change(zifuchuan a,int b)
{
    a.step++;
    if (b<4)       // +
    {
        if(a.num[b]==9)a.num[b]=1;
        else a.num[b]++;
    }
    else if (b < 8)  // -
    {
        if (a.num[b%4]==1)a.num[b%4]=9;
        else a.num[b%4]=a.num[b%4]-1;
    }
    else    // swap
    {
        int tmp;
        b%=4;
        tmp=a.num[b];
        a.num[b]=a.num[b+1];
        a.num[b+1]=tmp;
    }
    return a;
}

然后这里的vis数组要用上四维的:

struct zifuchuan
{
    int num[4];//四个数字
    int step;
}now,nex;
int vis[10][10][10][10];//每个数字的变换记录.

然后就是完整的AC代码:

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
struct zifuchuan
{
    int num[4];
    int step;
}now,nex;
int vis[10][10][10][10];
int mubiao[4];
char s1[5];
char s2[5];
 zifuchuan  change(zifuchuan a,int b)
{
    a.step++;
    if (b<4)       // +
    {
        if(a.num[b]==9)a.num[b]=1;
        else a.num[b]++;
    }
    else if (b < 8)  // -
    {
        if (a.num[b%4]==1)a.num[b%4]=9;
        else a.num[b%4]=a.num[b%4]-1;
    }
    else    // 换
    {
        int tmp;
        b%=4;
        tmp=a.num[b];
        a.num[b]=a.num[b+1];
        a.num[b+1]=tmp;
    }
    return a;
}
void bfs()
{
    queue<zifuchuan>s;
    memset(mubiao,0,sizeof(mubiao));
    memset(vis,0,sizeof(vis));
    for(int i=0;i<4;i++)
    {
        now.num[i]=s1[i]-'0';
        mubiao[i]=s2[i]-'0';
    }
    now.step=0;
    vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]=1;
    s.push(now);
    while(!s.empty())
    {
        now=s.front();
        if(now.num[0]==mubiao[0]&&now.num[1]==mubiao[1]&&now.num[2]==mubiao[2]&&now.num[3]==mubiao[3])
        {
            printf("%d\n",now.step);
            return  ;
        }
        s.pop();
        for(int i=0;i<11;i++)
        {
            nex=change(now,i);
            if(vis[nex.num[0]][nex.num[1]][nex.num[2]][nex.num[3]]==0)
            {
                s.push(nex);
                vis[nex.num[0]][nex.num[1]][nex.num[2]][nex.num[3]]=1;
            }
        }
    }
    return ;
    
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",s1,s2);
        bfs();
    }
}












你可能感兴趣的:(搜索,杭电,杭电,杭电1195,1195)