HDU 1198 Farm Irrigation

D - Farm Irrigation
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 1198

Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output

For each test case, output in one line the least number of wellsprings needed.
 

Sample Input

     
     
     
     
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output

     
     
     
     
2 3
 

题目大意是说:看,上面有张图表,分别A-K,对应不同的管道图。然后输入一个字母网格,看对应的管道图有几个在一堆,有几堆就打几个水桩。

自然就想到并查集,只是这里要处理一下,A-K的图,用一个结构体数组表示,1表示某个方向有接口,0表示没有,便于后面集合合并判断。看到别的大牛还有用二进制数表示的,直接位运算。高!改天我也试一下。

#include <stdio.h>
#define N 360000
int a[600][600],father[600][600];
typedef struct
{
    int u,d,l,r;
}Grid;
Grid grid[]={{0,0,0,0},{1,0,1,0},{1,0,0,1},{0,1,1,0},{0,1,0,1},{1,1,0,0},{0,0,1,1},{1,0,1,1},{1,1,1,0},{0,1,1,1},{1,1,0,1},{1,1,1,1}};
int fa[10000],size[10000];
void InitSet(int n){
    for(int i=1; i<=n; i++)
    {
        fa[i] = i;
        size[i]=1;
    }
}
int Find(int x)
{
    return fa[x] == x ? x : fa[x] = Find(fa[x]) ;
}
void Merge(int u ,int v)
{
    int fu = Find(u) , fv = Find(v) ;
    if(fu != fv)
    {
           fa[fv] = fu ;
           size[fu] += size[fv];
           size[fv] = 0 ;
    }
}
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n))
    {
        if(m<1||n<1)
            break;
        InitSet(m*n);
        char temp;
        for(int i=1;i<=m;i++)
        {
            getchar();
            for(int j=1;j<=n;j++)
            {
                scanf("%c",&temp);
                a[i][j]=temp-64;
            }
        }
        int k=1;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                father[i][j]=k++;
         for(int i=1;i<=m;i++)
         {
            for(int j=1;j<=n;j++)
            {
                if(grid[a[i][j-1]].r&&grid[a[i][j]].l)
                {
                    Merge(father[i][j-1],father[i][j]);
                }
                if(grid[a[i-1][j]].d&&grid[a[i][j]].u)
                {
                    Merge(father[i-1][j],father[i][j]);
                }
            }
        }
        int ans=0;
        for(int i=1;i<=m*n;i++)
            {
                if(size[i])
                    ans++;
            }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(HDU 1198 Farm Irrigation)