uva 10387 Billiard(平面几何)

Billiard

In a billiard table with horizontal side  a  inches and vertical side  b  inches, a ball is launched from the middle of the table. After  s  > 0 seconds the ball returns to the point from which it was launched, after having made  m  bounces off the vertical sides and  n  bounces off the horizontal sides of the table. Find the launching angle  A  (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.

Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.

Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are:  a , b s m , and  n , respectively. All numbers are positive integers not greater than 10000.

Input is terminated by a line containing five zeroes.

Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle  A  in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.

Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0

Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81
题目大意:有一个长为a宽为b的桌子,现在在桌子的中心放一小球,开始时小球的速度与水平方向有一个夹角,小球在s时间内在水平方向上与桌子相撞了n次,在垂直方向上与桌子相撞了m次,现在要求小球与水平方向所成的角度和速度大小。

解题思路:从整体来看,走过的长为a * m,宽为b * n。

#include<stdio.h>
#include<math.h>

int main(){
	int a, b, s, m, n;
	double pi = 3.141592653;
	while (scanf("%d%d%d%d%d", &a, &b, &s, &m, &n), a || b || s || m || n)
	{
		double leap = 1.0 * n * b / (m * a);
		double t = atan(leap);
		double v = (1.0 * n * b) / (sin(t) * s);
		t = t / pi * 180;
		printf("%.2lf %.2lf\n", t, v);
	}
	return 0;
}

你可能感兴趣的:(uva 10387 Billiard(平面几何))