POJ ——3069 Saruman's Army

Saruman's Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5873   Accepted: 2995

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of Runits, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

解析在代码里面了

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<math.h>
#define M(i,n,m) for(int i = n;i < m;i ++)
#define L(i,n,m) for(int i = n;i >= 0;i --)
#define N(n,m) memset(n,m,sizeof(n));
const int MAX = 1010;


using namespace std;
int n,r,a[MAX];


void solve()
{
    int i = 0,count = 0;
    while(i < n)    ///所有的点逐个遍历
    {
        int s = a[i ++];    ///s为每种情况中没有被覆盖的最左点的位置
        ///一直往右遍历,知道距s的距离大于r为止
        while(i < n && a[i] <= s + r)
            i ++;
        int p = a[i - 1];   ///要寻找的点
        ///一直往右遍历,知道距p的距离大于r为止
        while(i < n && a[i] <= p + r)
            i ++;
        count ++;   ///数量累加
    }
    printf("%d\n",count);
}


int main()
{
    while(cin >> r >> n)
    {
        if(r == -1 && n == -1)
            break;
        M(i,0,n)
        cin>>a[i];
        sort(a,a+n);
        solve();
    }
    return 0;
}

你可能感兴趣的:(算法,ACM,poj,贪心)