Description
Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.
Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input
The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4
-2 3
3 4 5 8
Sample Output
2
题目大意:若干个钩子,和若干个砝码,问为了使天平平衡有多少种挂法。
仔细分析一下会发现是一个01背包问题,当前是否要把砝码放到钩子上的问题。若使天平平衡需要两边的力距相等(力臂=重量 *臂长 = w[i]*c[k]),另dp[i][j],表示在挂上前i个物品,达到j状态的方法数。
由于距离c[i]的范围是-15~15,钩码重量的范围是1~25,钩码数量最大是20
因此最极端的平衡度是所有物体都挂在最远端,因此平衡度最大值为d=15*20*25=7500,避免负数下标的问题需要乘以原来数值的二倍。
所以力距的范围是0~150000.使使得数组开为 dp[1~20][0~15000],则当j=7500时天枰为平衡状态.
故可以推出转移方程:dp[i][j+w[i]*c[k] ]+=dp[i-1][j].
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
int dp[30][20010];
int c[20000],w[100];
int main()
{
int n,m,x,k,i,j,g;
while(~scanf("%d%d",&g,&n))
{
memset(dp,0,sizeof(dp));
for(i=1;i<=g;i++)
scanf("%d",&c[i]);
for(i=1;i<=n;i++)
scanf("%d",&w[i]);
dp[0][7500]=1;
for(i=1;i<=n;i++)
{
for(j=0;j<=15000;j++)
{
if(dp[i-1][j])
for(k=g;k>=1;k--)
{
dp[i][j+w[i]*c[k]]+=dp[i-1][j];
}
}
}
printf("%d\n",dp[n][7500]);
}
return 0;
}