UVA 575-Skew Binary

A - Skew Binary
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

 
 

When a number is expressed in decimal, the k-th digit represents a multiple of10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,

When a number is expressed in binary, the k-th digit represents a multiple of2k. For example,

In skew binary, the k-th digit represents a multiple of2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example,

The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

Input 

The input file contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

Output 

For each number, output the decimal equivalent. The decimal value of n will be at most 231 - 1 = 2147483647.

Sample Input 

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output 

44
2147483646
3
2147483647
4
7
1041110737


题目大意:

给你一个斜二进制的数,叫你算出他的十进制。


题目解析:

这题很简单没什么难度,把字符串转化为数字。再按照题目所给的公式,计算输出就好了。


#include<iostream>
#include<string>
#include<math.h>

using namespace std;

int main() {
	string num;
	while(cin>>num) {
		if(num == "0")
			break;
		int len = num.size();
		long long sum = 0;
		int tmp;
		for(int i=0;i<len;i++) {
			tmp = num[i]-'0';
			sum += tmp * (pow(2,len-i) - 1);
		}
		cout<<sum<<endl;	
	}
	return 0;
}

你可能感兴趣的:(binary,uva,skew)