ZOJ 3710 Friends(思维,最短路,图论)

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0
Sample Output

2
0
4

思维:k是2时。假如1和2是好朋友,并且1和3是好朋友。4和2是好朋友,并且4和3是好朋友。那么1和4是好朋友。
注意:假如5和1是好朋友,且6和4是好朋友,并且6和5是好朋友,那么1和6是好朋友。
所以每找到一组新的好朋友,都要对已知的进行更新。

下面是AC 代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define N 0x3fffffff

int e[1005][1005];
int main()
{
    int t,n,m,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(e,0,sizeof(e));
        int a,b;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            e[a][b]=1;
            e[b][a]=1;
        }
        int flag=1;
        int sum=0;
        while(flag==1)
        {
            flag=0;
            for(int i=0;i<n;i++)
            {
                for(int j=i+1;j<n;j++)
                {
                    if(e[i][j]==1)
                    {
                        continue;
                    }
                    int sumf=0;
                    for(int l=0;l<n;l++)
                    {
                        if(e[i][l]==1&&e[j][l]==1)
                        {
                            sumf++;
                        }
                    }
                    if(sumf>=k)
                    {
                        e[j][i]=1;
                        e[i][j]=1;
                        flag=1;
                        sum++;
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

你可能感兴趣的:(ZOJ)