poj2481 树状数组

http://poj.org/problem?id=2481

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.
我是看的他的~~~~
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define MAX 100005
using namespace std;
int c[MAX],ans[MAX],n,imax;
struct cow
{
    int l,r,id;
} a[MAX];
bool cmp(cow a,cow b)
{
    if(a.r==b.r)
        return a.l<b.l;
    return a.r>b.r;
}
int lowbit(int t)
{
    return t&(-t);
}
int sum(int t)
{
    int total=0;
    while(t>0)
    {
        total+=c[t];
        t-=lowbit(t);
    }
    return total;
}
void modify(int posi,int key)
{
    while(posi<=imax)
    {
        c[posi]+=key;
        posi+=lowbit(posi);
    }
}
int main()
{
    int i,j,k,n;
    while(scanf("%d",&n),n)
    {
        memset(c,0,sizeof(c));
        imax=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d%d",&a[i].l,&a[i].r);
            a[i].id=i;
            ++a[i].l;//树状数组是从1开始的,这样做能把所有的数都增大1,排除了零的干扰
            ++a[i].r;
            if(imax<a[i].l)
                imax=a[i].l;
        }
        sort(a+1,a+n+1,cmp);
        for(i=1; i<=n; i++)
        {
            if(i==1)
            {
                ans[a[i].id]=sum(a[i].l);
                modify(a[i].l,1);
            }
            else
            {
                if(a[i].l==a[i-1].l&&a[i].r==a[i-1].r)
                    ans[a[i].id]=ans[a[i-1].id];
                else
                    ans[a[i].id]=sum(a[i].l);
                modify(a[i].l,1);
            }
        }
        for(i=1; i<n; i++)
            printf("%d ",ans[i]);
        printf("%d\n",ans[i]);
    }
    return 0;
}


你可能感兴趣的:(poj2481 树状数组)