(1)题目大意:
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
题意是:将木棍放在机器里处理,第一根需要一分钟,剩余的如果大于等于前边放入的长度和重量,就不用费时间,否则需要一分钟,计算给出一组数的最少时间!用贪心算出最少降序序列个数!
(2)思路:
首先根据长度进行排序,然后在对重量进行比较,如果下一根小,则时间不加一,否则时间加以而且将此重量赋值。
(3)感想:
我就不明白了,这个题跟1001一模一样,我自己写的1001提交就对了,看着题目完全一样,就用以前的代码放上了,给我提示编译错误!!compile error,还真是日了狗了,所以我用1001的题目名字搜了一份代码,交在1008上,结果通过了,这里说明两份提完全一样的!!真不明白,日了狗了!
(4)代码:
自己的,跟1001一样:
#include<iostream>
#include<algorithm>
using namespace std;
struct My
{
int Wight, Long;
bool f = false;
bool operator<(const My &x)
{
if (x.Long == Long)
{
return Long < x.Long;
}
else
{
return Long < x.Long;
}
}
};
int main()
{
int n, m, mm = 0;
My my[5000];
cin >> m;
while (mm < m)
{
cin >> n;
for (int i = 0;i < n;i++)
{
cin >> my[i].Wight;
cin >> my[i].Long;
my[i].f = false;
}
sort(my, my + n);
int time = 0;
for (int i = 0;i < n; i++)
{
if (my[i].f == true)
{
continue;
}
else
{
time++;
my[i].f == true;
}
for (int j = i + 1;j < n;j++)
{
if (my[j].f == true)
{
continue;
}
else
{
if (my[j].Wight >= my[i].Wight&&my[j].Long >= my[i].Long)
{
my[j].f = true;
my[i].Long = my[j].Long;
my[i].Wight = my[j].Wight;
}
else
{
continue;
}
}
}
}
cout << time << endl;
mm++;
}
}
网上找的:
#include<stdio.h>
#include<stdlib.h>
typedef struct stu
{
int l
,w
;
}Lode
;
Lode s
[
5005
];
int cmp
(const void *a
,const void *b
)
{
Lode
*c
,*d
;
c
=(Lode
*)a
;
d
=(Lode
*)b
;
if(c
->l
!=d
->l
)
return d
->l
-c
->l
;
else return d
->w
-c
->w
;
}
int main()
{
int t
,n
,i
,j
,ans
;
scanf
(
"%d"
,&t
);
while(t
--)
{
scanf
(
"%d"
,&n
);
for(i
=
0
;i
<n
;i
++)
scanf
(
"%d%d"
,&s
[i
].l
,&s
[i
].w
);
qsort
(s
,n
,sizeof(s
[
0
]),cmp
);
ans
=n
; for(i
=
1
;i
<n
;i
++)
for(j
=
0
;j
<=i
-
1
;j
++)
{
if(s
[j
].l
>=s
[i
].l
&&s
[j
].w
>=s
[i
].w
)
{
ans
--;
s
[j
].l
=s
[i
].l
;
s
[j
].w
=s
[i
].w
;
s
[i
].l
=
0
;
s
[i
].w
=
0
;
break;
}
}
printf
(
"%d\n"
,ans
);
}
return
0
;
}