杭电ACM1002

(1)题目大意:

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

杭电ACM1002_第1张图片

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
   
   
   
   
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
   
   
   
   
200 0 0

如果田忌的马比国王的快,则赚200元,一样快不赔不赚,慢了就扣200.

(2)思路:

  按照从小到大排序,但是比较从大到小开始,如果田忌的快马比国王的慢,则用田忌的最慢的跟国王比,反之则用田忌快马比,一样快则再比较慢马,慢马田忌的快就直接比,反之用慢马跟鬼王最快的比较,若是一样快就用慢马跟国王最快的比。总的来说,就是总是用最慢的跟国王最快的比较。

(3)感想:

   还是挺难得,想了好多,但是总有疏漏。之前自己做的总是不通过,最后看看了看往后是哪个的人做的。却是感觉到了差距,以后要努力!

(4)代码:

#include<iostream>
using namespace std;
void swap(int *a, int *b)
{
 int temp = *a;
 (*a) = (*b);
 (*b) = temp;
}
int main()
{
 int n, i, k, mina, maxa, sum, maxb, minb;
 int a[1010], b[1010];

 while (cin>>n&&n!=0)
 {
  for (i = 0;i < n; i++)
   cin>>a[i];
  for (i = 0;i < n; i++)
   cin>>b[i];

  for (i = n - 1;i >= 0; --i)
  {
   for (k = 0;k < i; k++)
   {
    if (a[i] < a[k])
     swap(&a[i], &a[k]);
    if (b[i] < b[k])
     swap(&b[i], &b[k]);
   }
  }
  k = 0;
  mina = 0;
  minb = 0;
  maxa = n - 1;
  maxb = n - 1;
  for (i = 0; i < n; i++)
  {
   if (a[maxa] > b[maxb])
   {
    maxa--;
    maxb--;
    k++;
   }
   else if (a[maxa] < b[maxb])
   {
    mina++;
    maxb--;
    k--;
   }
   else
   {
    if (a[mina] < b[minb])
    {
     maxb--;
     mina++;
     k--;
    }
    else if (a[mina] > b[minb])
    {
     mina++;
     minb++;
     k++;
    }
    else
    {
     if (a[mina] < b[maxb])
     {
      maxb--;
      mina++;
      k--;
     }
    }
   }
  }
  sum = 200 * k;
  cout << sum << endl;
 }
 return 0;
}

你可能感兴趣的:(ACM,杭电)