HDU2955(01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18778 Accepted Submission(s): 6933

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4
6
dp【j】指的是到金额j时没被抓到的最大概率
dp数组里存储的是没被抓到的概率,这个概率会随着金额的增大一直变小下去。另外涉及到一个初始化的问题,当金额为零的时候肯定不会被抓到所以要设dp【0】=1

#include "cstring"
#include "cstdio"
#include "iostream"
#include "algorithm"
using namespace std;

double dp[10005];
int money[105];
double pb[105];
double max(double a,double b)
{
    if(a-b>0.00000001)
        return a;
    else 
        return b;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        double p;
        int n;
        scanf("%lf%d",&p,&n);
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lf",&money[i],&pb[i]);
            sum+=money[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=sum;j-money[i]>=0;j--)
            {
                dp[j]=max(dp[j],dp[j-money[i]]*(1-pb[i]));
            }

        }
        for(int i=sum;i>=0;i--)
        {
            if(1-dp[i]<p)
            {
                printf("%d\n",i);
                break;
            }
        }

    }
}

你可能感兴趣的:(HDU2955(01背包))