首字母变大写 HDU 2026



首字母变大写

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36290    Accepted Submission(s): 20164


Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 

Output
请输出按照要求改写后的英文句子。
 

Sample Input
   
   
   
   
i like acm i want to get an accepted
 

Sample Output
   
   
   
   
I Like Acm I Want To Get An Accepted
 

水题

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;

char st[101];
int main()
{
    int flag = 1,i,len;
    while(gets(st) != NULL)
    {
        flag = 1;
        len = strlen(st);
        for(i = 0; i < len ; i++)
        {
            if(flag && st[i] >='a' && st[i] <='z')
            {
                st[i] -= 32;
                flag = 0;
            }
            if(st[i]== ' ') flag =1;
            cout << st[i];
        }
        cout << endl;


    }
 return 0 ;
}

你可能感兴趣的:(ACM,HDU,杭电)