hdu 2680(dijkstra)

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
   
   
   
   
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
   
   
   
   
1 -1 把图反着看,即从朋友家出发,再看到我家附近的那几个站,哪个最近。 需要注意的是,题目给出同一条边的权值可能不同,比如他给了 1 2 3,然后下一行又给了1,2,1;这是合法的。。。因为你可以换一两快的公交车。。。。
#include <iostream>
#include <cmath>
#include <iomanip>
#include <cstdio>
using namespace std;

const int INF=99999999;
int dis[1005];int ma[1005][1005];int vis[1005];
int n,m,h;

void dj(int t)
{
    for(int i=1;i<=n;i++)
    {
        vis[i]=0;
        dis[i]=ma[t][i];
    }
   vis[t]=1;
    for(int i=1;i<=n;i++)//选n-1条边
    {
        int minn=INF;int temp;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&dis[j]<minn)
            {
                temp=j;
                minn=dis[j];
            }
            if(minn==INF)return ;
            vis[temp]=1;
            
            for(int j=1;j<=n;j++)
                if(!vis[j]&&ma[temp][j]+dis[temp]<dis[j])
                    dis[j]=ma[temp][j]+dis[temp];
    }

}

int main()
{
    while(scanf("%d%d%d",&n,&m,&h)!=EOF)
    {
        int x,y,z;

        for(int i=1;i<=1005;i++)
            for(int j=i;j<=1005;j++)
            ma[i][j]=ma[j][i]=INF;

        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(ma[y][x]>z)ma[y][x]=z;
        }
      dj(h);
      int nn;
      scanf("%d",&nn);
      int minn=INF;
      for(int i=0;i<nn;i++)
      {
          int j;scanf("%d",&j);
          if(dis[j]<minn)minn=dis[j];
      }
        if(minn==INF)cout<<-1<<endl;
        else
        cout<<minn<<endl;
    }
}


你可能感兴趣的:(hdu 2680(dijkstra))