【杭电oj】3047 - Zjnu Stadium(带权并查集)

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2464    Accepted Submission(s): 942


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

Input
There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output
For every case: 
Output R, represents the number of incorrect request.
 

Sample Input
   
   
   
   
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output
   
   
   
   
2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)
 

Source
2009 Multi-University Training Contest 14 - Host by ZJNU


还是带权并查集,在合并的部分有时候还是分不太清,还需要多练习啊!

代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
int f[50011];
int sum[50011];		//与其根节点的距离 
int find(int x)
{
	if (x!=f[x])
	{
		int t=f[x];
		f[x]=find(f[x]);
		sum[x]+=sum[t];
	}
	return f[x];
}
int main()
{
	int n,m;		//座位数,语句条数
	int x,y,l;
	int fx,fy;
	int ans;
	while (~scanf ("%d %d",&n,&m))
	{
		for (int i=1;i<=n;i++)
		{
			f[i]=i;
			sum[i]=0;
		}
		ans=0;
		while (m--)
		{
			scanf ("%d %d %d",&x,&y,&l);
			fx=find(x);
			fy=find(y);
			if (fx!=fy)		//根节点不同,合并 
			{
				f[fy]=fx;
				sum[fy]=sum[x]-sum[y]+l;		//这里交换的时候还是要注意,虽然以前AC过,现在还是弄不太清 
			}
			else		//根节点相同,判断语句是否与前面出现的冲突 
			{
				if (l!=sum[y]-sum[x])
					ans++;
			}
		}
		printf ("%d\n",ans);
	}
	return 0;
}


你可能感兴趣的:(【杭电oj】3047 - Zjnu Stadium(带权并查集))