POJ3278——Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silve r


开始没有对超过上界的进行判断,结果RE了三次。。。看别人的代码都用的普通队列,我用的最小优先队列,后来改成普通队列也能过,求路过的指导为什么这题用普通队列和优先队列没区别



#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int s,e;
bool vis[100010];

struct cmp
{
	int x;
	int step;
	friend bool operator < (const cmp a,const cmp b)
	{
		return a.step > b.step;
	}
};

void bfs()
{
	priority_queue<cmp>qu;
	memset(vis,0,sizeof(vis));
	while(!qu.empty())
		qu.pop();
	cmp temp1,temp2;
	temp1.x=s;
	temp1.step=0;
	qu.push(temp1);
	vis[temp1.x]=1;
	bool flag=false;
	int ans;
	while(!qu.empty())
	{
		temp1=qu.top();
		qu.pop();
		for(int i=0;i<3;i++)
		{
			if(i==0)
			{
				temp2.x=temp1.x-1;
				temp2.step=temp1.step+1;
			}
			else if(i==1)
			{
				temp2.x=temp1.x+1;
				temp2.step=temp1.step+1;
			}
			else
			{
				temp2.x=temp1.x*2;
				temp2.step=temp1.step+1;
			}
			if(temp2.x<0 || temp2.x>100010 || vis[temp2.x])
				continue;
			vis[temp2.x]=1;
			if(temp2.x==e)
			{
				ans=temp2.step;
				flag=true;
				break;
			}
			qu.push(temp2);
		}
		if(flag)
			break;
	}
	printf("%d\n",ans);
}

int main()
{
	while(~scanf("%d%d",&s,&e))
	{
		if(s==e)
		{
			printf("0\n");
			continue;
		}
		bfs();
	}
	return 0;
}


#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int s,e;
bool vis[100010];

struct cmp
{
	int x;
	int step;
};

void bfs()
{
	queue<cmp>qu;
	memset(vis,0,sizeof(vis));
	while(!qu.empty())
		qu.pop();
	cmp temp1,temp2;
	temp1.x=s;
	temp1.step=0;
	qu.push(temp1);
	vis[temp1.x]=1;
	bool flag=false;
	int ans;
	while(!qu.empty())
	{
		temp1=qu.front();
		qu.pop();
		for(int i=0;i<3;i++)
		{
			if(i==0)
			{
				temp2.x=temp1.x-1;
				temp2.step=temp1.step+1;
			}
			else if(i==1)
			{
				temp2.x=temp1.x+1;
				temp2.step=temp1.step+1;
			}
			else
			{
				temp2.x=temp1.x*2;
				temp2.step=temp1.step+1;
			}
			if(temp2.x<0 || temp2.x>100010 || vis[temp2.x])
				continue;
			vis[temp2.x]=1;
			if(temp2.x==e)
			{
				ans=temp2.step;
				flag=true;
				break;
			}
			qu.push(temp2);
		}
		if(flag)
			break;
	}
	printf("%d\n",ans);
}

int main()
{
	while(~scanf("%d%d",&s,&e))
	{
		if(s==e)
		{
			printf("0\n");
			continue;
		}
		bfs();
	}
	return 0;
}


你可能感兴趣的:(bfs)