POJ 1837 Balance(01背包 动态规划)

Balance

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12613   Accepted: 7903

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.  
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.  
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.  

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.  
It is guaranteed that will exist at least one solution for each test case at the evaluation.  

Input

The input has the following structure:  
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);  
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);  
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.  

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
 此题需要将问题转化为求解为平衡态的问题,最大为15*20*25=15000;根据力臂来确定平衡度,具体也是说不清,见大牛博客
http://blog.csdn.net/lyy289065406/article/details/6648094/
dp[i][ j+ w[i]*c[k] ]= ∑(dp[i-1][j]),进行一般01背包的套路进行求解
代码如下: 
#include<iostream>
#include<cstring>
using namespace std;
int dp[25][15001];
int main()
{
    int i,j,k,a,g,c[25],w[25];
    cin>>a>>g;
        for(i=1;i<=a;i++)
        cin>>c[i];
        for(i=1;i<=g;i++)
            cin>>w[i];
        memset(dp,0,sizeof(dp));//清空
        dp[0][7500]=1;//开始的平衡状态只有一种不挂钩码方法,
        for(i=1;i<=g;i++)//枚举种类
            for(j=0;j<=15000;j++)//枚举背包
        {
            if(dp[i-1][j])
            {
                for(k=1;k<=a;k++)
                    dp[i][j+w[i]*c[k]]+=dp[i-1][j];
            }
        }
        cout<<dp[g][7500]<<endl;
        return 0;
}


你可能感兴趣的:(动态规划,poj,背包)