2015区域赛长春网络赛 Elven Postman

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 762    Accepted Submission(s): 408


Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

2015区域赛长春网络赛 Elven Postman_第1张图片
 

Input
First you are given an integer  T(T10)  indicating the number of test cases.

For each test case, there is a number  n(n1000)  on a line representing the number of rooms in this tree.  n  integers representing the sequence written at the root follow, respectively  a1,...,an  where  a1,...,an{1,...,n} .

On the next line, there is a number  q  representing the number of mails to be sent. After that, there will be  q  integers  x1,...,xq  indicating the destination room number of each mail.
 

Output
For each query, output a sequence of move ( E  or  W ) the postman needs to make to deliver the mail. For that  E  means that the postman should move up the eastern branch and  W  the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
 

Sample Input
   
   
   
   
2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
 

Sample Output
   
   
   
   
E WE EEEEE

水题,自己一直在纠结如何删除一棵树,谢了一种方法没有成功。。。最后每个case开头添加root=NULL

如果知道如何删除一个树,请留言

#include<iostream>

#include<fstream>
#include<set>
#include<stack>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;


typedef long long LL;
const int MAX=0xfffffff;
struct node{
    int data;
    node *l,*r;
}tree,*root;
void insert(node *&t,int k)
{
    if(t==NULL)
    {
        t=(node *)malloc(sizeof(node));
        t->data=k;
        t->l=t->r=NULL;
        return;
    }
    if(k<t->data) insert(t->l,k);
    else insert(t->r,k);
}
string S;
void search(node *t,int k)
{
    if(t==NULL||k==t->data)  return ;
    else if(k<t->data)
    {
        S+="E";
        search(t->l,k);
    }
    else
    {
        S+="W";
        search(t->r,k);
    }
}


int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        root=NULL;
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            int a;
            scanf("%d",&a);
            insert(root,a);
        }
        int q;
        scanf("%d",&q);
        while(q--)
        {
            S="";
            int a;
            scanf("%d",&a);
            search(root,a);
            cout<<S<<endl;
        }
    }
    return 0;
}

你可能感兴趣的:(构造树)