106 miles to Chicago
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 3174 |
|
Accepted: 1494 |
|
Special Judge |
Description
In the movie "Blues Brothers", the orphanage where Elwood and Jack were raised may be sold to the Board of Education if they do not pay 5000 dollars in taxes at the Cook Country Assessor's Office in Chicago. After playing a gig in the Palace Hotel ballroom to earn these 5000 dollars, they have to find a way to Chicago. However, this is not so easy as it sounds, since they are chased by the Police, a country band and a group of Nazis. Moreover, it is 106 miles to Chicago, it is dark and they are wearing sunglasses.
As they are on a mission from God, you should help them find the safest way to Chicago. In this problem, the safest way is considered to be the route which maximises the probability that they are not caught.
Input
The input contains several test cases.
Each test case starts with two integers n and m (2 <= n <= 100 , 1 <= m <= n*(n-1)/2). n is the number of intersections, m is the number of streets to be considered.
The next m lines contain the description of the streets. Each street is described by a line containing 3 integers a, b and p (1 <= a, b <= n , a != b, 1 <= p <= 100): a and b are the two end points of the street and p is the probability in percent that the Blues Brothers will manage to use this street without being caught. Each street can be used in both directions. You may assume that there is at most one street between two end points.
The last test case is followed by a zero.
Output
For each test case, calculate the probability of the safest path from intersection 1 (the Palace Hotel) to intersection n (the Honorable Richard J. Daley Plaza in Chicago). You can assume that there is at least one path between intersection 1 and n.
Print the probability as a percentage with exactly 6 digits after the decimal point. The percentage value is considered correct if it differs by at most 10-6 from the judge output. Adhere to the format shown below and print one line for each test case.
Sample Input
5 7
5 2 100
3 5 80
2 3 70
2 1 50
3 4 90
4 1 85
3 1 70
0
Sample Output
61.200000 percent
//好吧,承认自己是傻了,题目没看懂~~其实就是flody的变形啊。输入的n表示路线,m表示有几组
而接下去的m行,输入路线,以及安全的概率~对啊,就是求从起点到终点的最小概率,用乘法~傻不傻
代码:
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
double map[101][101];
int i,j,k,m,n,x,y,p;
void floyd(){
for(k=1;k<=n;k++)
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
if(map[i][j]<map[i][k]*map[k][j])
map[i][j]=map[i][k]*map[k][j];
}
void init(){
for(i=1;i<=n;i++)
for(j=1;j<=n;j++){
if(i==j) map[i][j]=1;
else
map[i][j]=0;
}
}
void read(){
cin>>m;
for(i=0;i<m;i++){
cin>>x>>y>>p;
map[x][y]=map[y][x]=(double )p/100;
}
}
int main(){
while(cin>>n&&n){
init();
read();
floyd();
printf("%.6lf percent\n",map[1][n]*100);
}
return 0;
}