Description
维护一个W*W的矩阵,初始值均为S.每次操作可以增加某格子的权值,或询问某子矩阵的总权值.修改操作数M<=160000,询问数Q<=10000,W<=2000000.
Input
第一行两个整数,S,W;其中S为矩阵初始值;W为矩阵大小
接下来每行为一下三种输入之一(不包含引号):
“1 x y a”
“2 x1 y1 x2 y2”
“3”
输入1:你需要把(x,y)(第x行第y列)的格子权值增加a
输入2:你需要求出以左上角为(x1,y1),右下角为(x2,y2)的矩阵内所有格子的权值和,并输出
输入3:表示输入结束
Output
对于每个输入2,输出一行,即输入2的答案
Sample Input
0 4
1 2 3 3
2 1 1 3 3
1 2 2 2
2 2 2 3 4
3
Sample Output
3
5
Solution
令初始值为0(不为0则在每次查询结果上加上s*(x2-x1+1)*(y2-y1+1)即可)
以sum(x,y)表示棋盘上所有在点(x,y)左上方的元素之和,那么对于每一次查询操作x1,y1,x2,y2,答案即为sum(x2,y2)+sum(x1-1,y1-1)+sum(x1-1,y2)-sum(x2,y1-1),将每次查询操作看作在棋盘上(x1-1,y2),(x2,y1-1),(x1-1,y1-1),(x2,y2)四个点插入值为0的点,那么问题转化为对于每个插入操作,如何求在此操作之前插入的点中处于该点左上方的点权之和,这个三维偏序关系的统计可以通过CDQ分治来实现,按插入顺序分治,ans[i]表示插入的第i个元素的查询结果,对[l,mid]和[mid+1,r]中的元素都以x为第一关键字升序排,以y为第二关键字升序排,对于[mid+1,r]中的每个i,将区间[l,mid]中所有满足j.y<=i.y的j以j.x为下标,j.num为键值插入到树状数组中,那么累加树状数组中所有下标小于等于i.x的元素键值之和累加到ans[i]中即可,最后再根据给每个操作打的标记(标记其属于第几次查询)和其对答案的贡献状态(+或-)计算每次查询的结果即可
Code
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 1111111
int s,n,res,tot,ans[maxn],cnt,h[maxn];
struct node
{
int x,y,num,id,sta,flag,ans;
node(){};
node(int x,int y,int num,int id,int sta,int flag,int ans):x(x),y(y),num(num),id(id),sta(sta),flag(flag),ans(ans){};
bool operator <(const node &a)const
{
if(y!=a.y)return y<a.y;
if(x!=a.x)return x<a.x;
return id<a.id;
}
}p[maxn],q[maxn];
struct BIT
{
#define lowbit(x) (x&(-x))
int b[maxn];
void init()
{
memset(b,0,sizeof(b));
}
void update(int x,int v)
{
while(x<=n)
{
b[x]+=v;
x+=lowbit(x);
}
}
int query(int x)
{
int ans=0;
while(x)
{
ans+=b[x];
x-=lowbit(x);
}
return ans;
}
}bit;
void CDQ(int l,int r)
{
if(l==r)return ;
int mid=(l+r)>>1;
CDQ(l,mid);
CDQ(mid+1,r);
sort(p+l,p+mid+1);
sort(p+mid+1,p+r+1);
int j=l;
for(int i=mid+1;i<=r;i++)
{
for(;j<=mid&&p[j].y<=p[i].y;j++)
if(p[j].num)bit.update(p[j].x,p[j].num);
if(!p[i].num)p[i].ans+=bit.query(p[i].x);
}
for(int i=l;i<j;i++)
if(p[i].num)bit.update(p[i].x,-p[i].num);
merge(p+l,p+mid+1,p+mid+1,p+r+1,q);
for(int i=0;i<r-l+1;i++)p[l+i]=q[i];
}
int main()
{
while(~scanf("%d%d",&s,&n))
{
n++;
bit.init();
memset(ans,0,sizeof(ans));
res=0,tot=0,cnt=0;
int op,x1,y1,x2,y2,A;
while(scanf("%d",&op),op!=3)
{
if(op==1)
{
scanf("%d%d%d",&x1,&y1,&A);
p[++res]=node(x1,y1,A,res,0,0,0);
h[++cnt]=x1,h[++cnt]=y1;
}
else if(op==2)
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
p[++res]=node(x1-1,y1-1,0,res,1,++tot,0);
p[++res]=node(x1-1,y2,0,res,-1,tot,0);
p[++res]=node(x2,y1-1,0,res,-1,tot,0);
p[++res]=node(x2,y2,0,res,1,tot,0);
h[++cnt]=x1-1,h[++cnt]=y1-1,h[++cnt]=x2,h[++cnt]=y2;
ans[tot]+=s*(x2-x1+1)*(y2-y1+1);
}
}
sort(h+1,h+cnt+1);
cnt=unique(h+1,h+cnt+1)-h-1;
for(int i=1;i<=res;i++)
{
p[i].x=lower_bound(h+1,h+cnt+1,p[i].x)-h;
p[i].y=lower_bound(h+1,h+cnt+1,p[i].y)-h;
}
CDQ(1,res);
for(int i=1;i<=res;i++)
ans[p[i].flag]+=p[i].sta*p[i].ans;
for(int i=1;i<=tot;i++)
printf("%d\n",ans[i]);
}
return 0;
}