HDU2199:Can you solve this equation?(二分)

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
   
   
   
   
2 100 -4
 

Sample Output
   
   
   
   
1.6152 No solution!
 


 

一开始跑去百度一元四次方程的解,直接就被吓尿了,然后知道用二分做之后,发现二分还能解决这样的题目,数学无法做到的事情用程序可以很简单的就做到了

 

#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <math.h>
using namespace std;

double cal(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double n;
        scanf("%lf",&n);
        if(cal(0)>n || cal(100)<n)
        {
            printf("No solution!\n");
            continue;
        }
        double l = 0.0,r = 100.0;
        double mid = (l+r)/2;
        while(fabs(cal(mid)-n)>1e-5)
        {
            if(cal(mid)>n)
                r = mid-1;
            else
                l = mid+1;
            mid = (l+r)/2;
        }
        printf("%.4f\n",mid);
    }

    return 0;
}


 

你可能感兴趣的:(HDU,二分)