Anniversary party(树形DP)


Link:http://acm.hdu.edu.cn/showproblem.php?pid=1520


Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5702    Accepted Submission(s): 2612


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
   
   
   
   
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
   
   
   
   
5
 

Source
Ural State University Internal Contest October'2000 Students Session
 


AC  code:


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#define MAXN 1000010
#define LL long long
using namespace std;
struct nofe{
	int v;
	int next;
}edge[MAXN];
int head[MAXN];
int n,u,v,tot;
int dp[MAXN][2];
void init()
{
	memset(head,-1,sizeof(head));
	tot=0;
}
void add(int from,int to,int w)
{
	edge[tot].v=to;
	edge[tot].next=head[from];
	head[from]=tot++;
}
void dfs(int p,int fa)
{
	for(int i=head[p];i!=-1;i=edge[i].next)
	{
		int v=edge[i].v;
		if(v==fa)
			continue;
		dfs(v,p);
		dp[p][1]+=dp[v][0];
		dp[p][0]+=max(dp[v][0],dp[v][1]);
	}
}
int main()
{
	//freopen("in.txt","r",stdin);
	while(cin>>n)
	{
		for(int i=1;i<=n;i++)
		{
			cin>>dp[i][1];
			dp[i][0]=0;
		}
		init();
		while(1)
		{
			cin>>u>>v;
			if(u==0&&v==0)
				break;
			add(u,v,0);
			add(v,u,0);
		}
		
		dfs(1,-1);
		int ans=max(dp[1][0],dp[1][1]);
		printf("%d\n",ans);
	}
	return 0;
}




你可能感兴趣的:(动态规划,ACM)