POJ 3177——Redundant Paths && POJ3352——Road Construction

3352:


Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

Source

题目就是在问加多少条边以后,整张图就成为了双连通图,所以做法就是缩点然后得到一棵树,求树叶子节点的个数


#include<set>
#include<map>
#include<list>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const int maxn=5010;

struct node
{
	int to;
	int id;
	int next;
}edge[maxn<<1];
int head[maxn];
int tot,index,cnt,n;
int block[maxn];
int color[maxn];
int low[maxn];
int DFN[maxn];
bool instack[maxn];
int du[maxn];

void addedge(int from,int to,int id)
{
	edge[tot].id=id;
	edge[tot].to=to;
	edge[tot].next=head[from];
	head[from]=tot++;
}

void tarjan(int u,int fa)
{
	instack[u]=1;
	DFN[u]=low[u]=++index;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].to;
		if(fa==edge[i].id)
			continue;
		if(!instack[v])
		{
			tarjan(v,edge[i].id);
			low[u]=min(low[u],low[v]);
		}
		else
			low[u]=min(DFN[v],low[u]);
	}
}

void set_color()
{
	for(int i=1;i<=n;i++)
		for(int j=head[i];j!=-1;j=edge[j].next)
			if(low[i]!=low[edge[j].to])
			{
				du[low[i]]++;
				du[low[edge[j].to]]++;
			}
}

int solve()
{
	memset(DFN,0,sizeof(DFN));
	memset(low,0,sizeof(low));
	memset(du,0,sizeof(du));
	memset(color,-1,sizeof(color));
	memset(instack,0,sizeof(instack));
	index=0;
	tarjan(1,-1);
	set_color();
	int leave=0;
	for(int i=1;i<=n;i++)
	{
		if(du[i]/2==1)
			leave++;	
	}
	return (leave+1)/2;
}

int main()
{
	int m;
	while(~scanf("%d%d",&n,&m))
	{
		memset(head,-1,sizeof(head));
		tot=0;
		int s,t;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&s,&t);
			addedge(s,t,i);
			addedge(t,s,i);
		}
		printf("%d\n",solve());
	}
	return 0;
}


你可能感兴趣的:(图的连通性)