606第三周周六赛F - Proud Merchants

F - Proud Merchants
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 3466

Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 

 

Input

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 

 

Output

For each test case, output one integer, indicating maximum value iSea could get. 

 

Sample Input

      
      
      
      
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output

      
      
      
      
5 11
分析:

本题是背包问题,装还是不装哪个利益比较大,一定要分析出来排序的关键,正确的处理问题


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct value
{
    int p,q,v;
} a[550];
int cmp( value x,value y)
{
    return x.q-x.p<y.q-y.p;
}
int main()
{
    int m,n,i,j,s,b[5050];
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        memset(b,0,sizeof(b));
        for(i=0; i<m; i++)
            scanf("%d %d %d",&a[i].p,&a[i].q,&a[i].v);
        sort(a,a+m,cmp);
        for(i=0; i<m; i++)
            for(j=n; j>=a[i].q; j--)
                b[j]=b[j]>b[j-a[i].p]+a[i].v?b[j]:b[j-a[i].p]+a[i].v;
        printf("%d\n",b[n]);
    }
    return 0;
}


你可能感兴趣的:(背包)