【二分匹配】 hdu2458 Kindergarten

Kindergarten

http://acm.hdu.edu.cn/showproblem.php?pid=2458



Problem Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
 

Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.
 

Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
 

Sample Input
   
   
   
   
2 3 3 1 1 1 2 2 3 2 3 5 1 1 1 2 2 1 2 2 2 3 0 0 0
 

Sample Output
   
   
   
   
Case 1: 3 Case 2: 4

题意:有一堆男孩和女孩,男孩和男孩之间,女孩和女孩之间互相认识,给出一堆男孩女孩之间认识的关系,问最多能邀请几个人去party,(邀请人之间互相直接认识)。

解法:如果按认识的人之间连边,那么就会变成找一个最大完全子图,变得十分复杂。仔细分析后,按不认识的人之间连边,就把问题变成 ans = n - 最大独立点. 最大独立点就做一次最大匹配即可。

//匈牙利算法
//独立集:任意两点都不相连的顶点的集合
//独立数:独立集中顶点的个数
//完全子图:任意两点都相连的顶点的集合
//最大完全数:最大完全子图中顶点的个数
//最大完全数=原图的补图的最大独立数
//最小点覆盖数 = 最大匹配数
//最大独立顶点集 = 顶点总数—最大匹配数
//最小路径覆盖数 = 顶点总数—最大匹配数
#include<cstdio>
#include<cstring>
using namespace std;
bool path[205][205],visit[205];
int match[205];
bool SearchPath(int s,int m)
{
    for(int i=1; i<=m; ++i)
    {
        if(!path[s][i]&&!visit[i])
        {
            visit[i]=true;
            if(match[i]==-1||SearchPath(match[i],m))
            {
                match[i]=s;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int a,b,n,m,r;
    for(int tt=1; scanf("%d%d%d",&n,&m,&r); ++tt)
    {
        if(n+m+r==0)  break;
        memset(path,false,sizeof(path));
        for(int i=0; i<r; ++i)
        {
            scanf("%d%d",&a,&b);
            path[a][b]=true;
        }
        for(int i=1;i<=n;++i)
            path[i][i]=true;
        int summ=0;
        memset(match,-1,sizeof(match));
        for(int i=1; i<=n; ++i)
        {
            memset(visit,0,sizeof(visit));
            if(SearchPath(i,m))
                summ++;
        }
        printf("Case %d: %d\n",tt,n+m-summ);
    }
}

来源: http://blog.csdn.net/acm_ted/article/details/7773725

你可能感兴趣的:(【二分匹配】 hdu2458 Kindergarten)