hdoj 1323 Perfection

Perfection

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1963    Accepted Submission(s): 1172


Problem Description
From the article Number Theory in the 1994 Microsoft Encarta: "If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."
Given a number, determine if it is perfect, abundant, or deficient.

Input
A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.

Output
The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

Sample Input
   
   
   
   
15 28 6 56 60000 22 496 0

Sample Output
   
   
   
   
PERFECTION OUTPUT 15 DEFICIENT 28 PERFECT 6 PERFECT 56 ABUNDANT 60000 ABUNDANT 22 DEFICIENT 496 PERFECT END OF OUTPUT
水题:
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
int max(int x,int y)
{
	return x>y?x:y; 
}
int a[110];
char str[10];
int f(int n)
{
	int i;
	int sum=0;
	for(i=1;i<n;i++)
	{
		if(n%i==0)
		{
			sum+=i;
		}
	}
	return sum;
}
int main()
{
	int n;
	int num;
	int t,i=0,j,l;
    t=0;num=0;
	memset(a,0,sizeof(a));
	while(scanf("%d",&n)&&(n!=0))
	{
	    a[t]=n;
	    sprintf(str,"%d",a[t]);
	    t++;
	    num=max(strlen(str),num);
	}
	printf("PERFECTION OUTPUT\n");
	for(i=0;i<t;i++)
	{
	    printf("%5d  ",a[i]);
	    if(f(a[i])==a[i])
	    printf("PERFECT\n");
	    else if(f(a[i])>a[i])
	    printf("ABUNDANT\n");
	    else 
	    printf("DEFICIENT\n");
	}
	printf("END OF OUTPUT\n");
	return 0;
}

 

你可能感兴趣的:(hdoj 1323 Perfection)