ZOJ-3204 Connect them(最小生成树)

ZOJ-3204 Connect them

                        Time Limit: 1 Second      Memory Limit: 32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ……

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of “lexicography small”) If you cannot connect them, just output “-1” in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1
Hints:
A solution A is a line of p integers: a1, a2, …ap.
Another solution B different from A is a line of q integers: b1, b2, …bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= p, r <= q) such that ai = bi for all 0 < i < r and ar < br
OR
(2) p < q and ai = bi for all 0 < i <= p

题目大意:有几台电脑,怎么用最少的费用把他们连接起来。

题目思路:最小生成树问题。先将边从小到大排序,依次把边两端的点用并查集合并。需要注意的是,题目中给出的矩阵上三角和下三角是相同的,即只需处理一半就可以啦。

题目链接:zoj 3204

以下是代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <cstring>
#include <set>
#include <functional>
#include <numeric>
#include <sstream>
#include <stack>
#include <map>
#include <queue>
using namespace std;
int k = 0;
int cnt = 0;
int n;
struct node{
    int d;
    int ii;
    int jj;
}num[100100],road[100100];
int fa[200];
int getfather(int v)
{
    if (fa[v] == -1)
        return v;
    else 
        return fa[v] = getfather(fa[v]);
}
bool cmp (node a, node b)
{
    if (a.d != b.d)
        return a.d < b.d;
    else if (a.ii != b.ii)
        return a.ii < b.ii;
    else
        return a.jj < b.jj;
}
bool comp(node a, node b)
{
    if (a.ii != b.ii)
        return a.ii < b.ii;
    else
        return a.jj < b.jj;
}
void kruscal ()
{
    cnt = 0;
    memset(fa,-1,sizeof(fa));
    for (int i = 0; i < k; i++)
    {
        int u = num[i].ii;
        int v = num[i].jj;
        int fau = getfather(u);
        int fav = getfather(v);
        if (fau != fav)
        {
            road[cnt++] = num[i];
            fa[fau] = fav;
        }
    }   
} 
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        k = 0;
        cnt = 0;
        for (int i = 1; i <= n; i++)
        {
            for (int j = 1; j <= n; j++)
            {
                int g;
                scanf("%d",&g);
                if (i < j && g != 0)
                {
                    num[k].d = g;
                    num[k].ii = i;
                    num[k].jj = j;
                    k++;                
                }           
            }
        }
        sort(num,num + k,cmp);      
        kruscal();
        if (cnt != n - 1)
        {
            printf("-1\n");
            continue;
        }
        else{
            sort(road,road + cnt,comp);
            printf("%d %d",road[0].ii,road[0].jj);
            for (int i = 1; i < cnt; i++)
            {
                printf(" %d %d",road[i].ii,road[i].jj);
            }
        printf("\n");               
        }
    }
    return 0;
}

你可能感兴趣的:(kruscal)