POJ_3356——最短编辑距离,动态规划

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

 

Certainly, we would like to minimize the number of all possible operations.

Illustration
A G T A A G T * A G G C

 | | |       |   |   | |

 A G T * C * T G A C G C

 

Deletion: * in the bottom line Insertion: * in the top line Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

 |  |  |        |     |     |  |

 A  G  T  C  T  G  *  A  C  G  C

 

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where nm.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC

11 AGTAAGTAGGC

Sample Output

4


关于最短编辑距离可以看一下我的蓝桥杯子栏中的文章,那里有些分析
这题我只是用来测试蓝桥杯里面的“DNA比对”这题,顺便水过的 - -
#include <iostream>

#include <cstring>

#include <algorithm>

using namespace std;



const int N = 10000;

int main()

{

    int n1, n2;

    char a[N], b[N];

    while(cin >> n1 >> a >> n2 >> b)

    {

        int d1[N + 1] = {0}, d2[N + 1] = {0};

        for(int i = 0; i <= N; i++)

        {

            d1[i] = i;

        }



        for(int i = 1; i <= n1; i++)      //a(0, i)

        {

            d2[0] = i;

            for(int j = 1; j <= n2; j++)  //b(0, j)

            {

                d2[j] = min(d2[j-1] + 1, d1[j] + 1);

                if(a[i - 1] == b[j - 1])

                {

                    d2[j] = min(d2[j], d1[j-1]);

                }

                else

                {

                    d2[j] = min(d2[j], d1[j-1] + 1);

                }

            }

            for(int k = 0; k <= N; k++)

            {

                d1[k] = d2[k];

            }

        }

        cout << d2[n2] << endl;

    }

    return 0;

}

 

你可能感兴趣的:(动态规划)