杭电1272 并查集

小希的迷宫

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27063    Accepted Submission(s): 8353


Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 
杭电1272 并查集
 

Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。 
整个文件以两个-1结尾。
 

Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 

Sample Input
  
    
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
  
    
Yes Yes No


#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include<queue>
#include<stack>
#include<map>
using namespace std;
#define lson ((root<<1)+1)
#define rson ((root<<1)+2)
#define MID ((l+r)>>1)
typedef long long ll; typedef pair<int,int> P; const int maxn=100000; const int base=1000; const int inf=999999; int a[maxn]; void build(int n) { for(int i=0;i<n;i++)
        a[i]=i; } int find(int x) { if(a[x]!=x)
        a[x]=find(a[x]); return a[x]; } void  add(int x,int y) {
    x=find(x);
    y=find(y);
    //if(x==y)return;
    a[x]=y; } int main() { int n,m,i,j,k,t; int x,y; while(1) {
        memset(a,0,sizeof(a)); int ok=0; while(cin>>x>>y) { if(x==0&&y==0)break; if(x==-1&&y==-1) return 0; if(a[x]==0)a[x]=x; if(a[y]==0)a[y]=y; if(find(x)==find(y))ok=1;//判断是否构成环
 else if(ok!=1)
                add(x,y); } int sum; for(i=1, sum=0;i<=maxn;i++) { if(a[i]==i)sum++;//检查是否有孤立点
            a[i]=0; } if(sum>1||ok==1)
            puts("No"); else
            puts("Yes"); } return 0 ; }






#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include<queue>
#include<stack>
#include<map>
using namespace std;
#define lson ((root<<1)+1)
#define rson ((root<<1)+2)
#define MID ((l+r)>>1)
typedef long long ll; typedef pair<int,int> P; const int maxn=100000; const int base=1000; const int inf=999999; int a[maxn]; void build(int n) { for(int i=0;i<n;i++)
        a[i]=i; } int find(int x) { if(a[x]!=x)
        a[x]=find(a[x]); return a[x]; } void  add(int x,int y) {
    x=find(x);
    y=find(y);
    //if(x==y)return;
    a[x]=y; } int main() { int n,m,i,j,k,t; int x,y; while(1) {
        memset(a,0,sizeof(a)); int ok=0; while(cin>>x>>y) { if(x==0&&y==0)break; if(x==-1&&y==-1) return 0; if(a[x]==0)a[x]=x; if(a[y]==0)a[y]=y; if(find(x)==find(y))ok=1;//判断是否构成环
 else if(ok!=1)
                add(x,y); } int sum; for(i=1, sum=0;i<=maxn;i++) { if(a[i]==i)sum++;//检查是否有孤立点
            a[i]=0; } if(sum>1||ok==1)
            puts("No"); else
            puts("Yes"); } return 0 ; }

你可能感兴趣的:(并查集)